jeudi 20 décembre 2012

Exemple de modélisation d'annuaire LDAP

Administrateur du ministère de la défense, je dois gérer les 3 armées, les matériels, les logiciels. Seuls les serveurs sont communs à tout le monde. Les personnels sont gérés par chaque armée, sauf au ministère.

.fr c=fr
|-.gouv o=gouv
      |-Ministère ou=ministere
            |-Air
                  |-Utilisateurs
                  |-Logiciels
                  |-Matériel
                        |-Computers
                        |-Phones
                        |-Routers
            |-Terre

                  |-Utilisateurs
                  |-Logiciels
                  |-Matériel
                        |-Computers
                        |-Phones
                        |-Routers

            |-Marine

                  |-Utilisateurs
                  |-Logiciels
                  |-Matériel
                        |-Computers
                        |-Phones
                        |-Routers

      |-Serveurs
      |-Utilisateurs

mercredi 19 décembre 2012

NAT / PAT Sur routeur Cisco


Préalable:

On a configuré un switch avec deux Vlans, un lien trunk entre le switch et le routeur. Les deux PC se trouvent chacun dans un réseau différent (192.168.1.0 et 192.168.2.0) et dans un Vlan différent. Le routeur dispose de deux ports virtuels sur son interface trunk: 192.168.1.1 (vlan2) et 192.168.2.1 (vlan3).

L'adresse publique de notre routeur est 10.2.18.97. Tous les masques sont en /24.

Identification des interfaces (A faire en premier, quel que soit le type de NAT)

Avant tout, il faut identifier les interfaces publiques et privées.
conf t
         interface fastEthernet 0/1

                  ip nat outside → Si l'interface est publique
                  ex
         interface fastEthernet 0/0.20
                  ip nat inside → Si l'interface est privée
                  ex

Inside Static NAT :

On va créer manuellement une translation :
conf t         ip nat inside source static <local IP> <global IP>

On visualise la table des translations :
show ip nat translations

Pour le désactiver :
conf t         no ip nat inside source static <local IP> <global IP>  
         (Répondre « yes » si le routeur demande si les routes doivent-être supprimées)

Inside Static NAT+PAT :

Avant tout, désactiver toute translation statique déjà en place (no ip nat inside...). Si le routeur refuse de le faire, nous disposons d'une commande "clear ip nat..." permettant de vider la table de translation.

On recrée maintenant une translation statique, mais en précisant les numéros de port:
ip nat inside source static tcp 192.168.2.2 80 10.2.18.97 200

Tout paquet envoyé à l'adresse 10.2.18.24 sur le port 200 sera maintenant redirigé vers l'adresse 192.168.1.2 sur le port 80.

Attention : A ce stade, le ping ne peut plus passer (ping utilise ICMP). On peut afficher la table des translations avec cette commande:
Router#show ip nat translations
Pro Inside global          Inside local       Outside local       Outside global
tcp 10.2.18.97:200     192.168.2.2:80            ---                              ---
On peut tenter d'établir une connexion pour vérifier le bon fonctionnement. Depuis une machine extérieure, taper:
telnet 10.2.18.97 200

La connexion sera refusée, aucun service telnet n'étant installé sur notre machine 192.168.1.2.
En affichant de nouveau la table des translations, on constate que notre tentative de connexion telnet a ouvert une entrée dans la table:

Table affichée:
Pro Inside global Inside local Outside local Outside global tcp 10.2.18.97:200 192.168.2.2:80 10.2.12.4:3696 10.2.12.4.3696 


Inside Dynamic NAT :

On va créer une access-list listant les machines autorisée à être NATées. Dans mon cas :
conf t

         access-list 12 permit 192.168.0.0 0.0.255.255

Vérifiable par :
show access-lists

On créer maintenant un pool d'adresses utilisables.
ip nat pool coucou 10.2.18.97 10.2.18.99 prefix-length 24 → masque en notation CIDR (= /24)


On active maintenant le NAT :
ip nat inside source list 12 pool coucou → Les adresses de l'ACL 12 seront natées derrière les adresses du pool « coucou »

         OU
Lorsque l'on désire nater plusieurs adresses derrière l'adresse externe du routeur (ce qui est le cas sur les box opérateur des particuliers) :
ip nat inside source list 12 fastEthernet0/0 overload → Les adresses de l'ACL 12 seront natées derrière l'adresse de l'interface Fa0/0.


Inside Dynamic NAT + PAT :

On va créer une access-list listant les machines autorisée à être NATées. Dans mon cas :
conf t

         access-list 12 permit 192.168.0.0 0.0.255.255

Vérifiable par :
show access-lists

On créer maintenant un pool d'adresses utilisables (une seule adresse ici) :
ip nat pool coucou 10.2.18.97 10.2.18.97 prefix-length 24 → masque en notation CIDR (= /24)


On active maintenant le NAT :
ip nat inside source list 12 pool coucou overload → Les adresses de l'ACL 12 seront natées derrière les adresses du pool « coucou ». L'adresse pourra être utilisée simultanément par plusieurs machines (« overload » = PAT).


On constate que les adresses sont bien natées derrière une seule IP :
Router(config)#do sho ip nat transPro Inside global Inside local Outside local Outside global icmp 10.2.18.97:50950 192.168.2.2:50950 10.2.18.1:50950 10.2.18.1:50950 icmp 10.2.18.97:38918 192.168.3.2:38918 10.2.18.1:38918 10.2.18.1:38918 

Outside Static NAT (Principe uniquement):

On crée une ACL listant les adresses IP externes.
On crée un pool d'adresses qui seront utilisées pour nater.

La ligne finale sera de la forme :
ip nat outside source list 12 pool coucou overload 

Configurer deux adresses IP sur une seule interface de routeur Cisco

Deux méthodes:

1 - Par IP secondaire

ip address  <@IP> <Masque>
ip address <@IP><Masque> secondary

2 - Avec des Vlans

On ne peut accéder aux sous-interfaces d'un routeur Cisco que lorsque les Vlans sont activés.
Pour cela, on configure (comme d'habitude) un lien trunk entre le port du routeur et un switchs, puis on ajoute les ports du switch dans les Vlans.

vendredi 7 décembre 2012

Liste commandes TP Services Réseau n°2


TP Services Réseau n°2
1. Démarrer une VM
2. Configurer le réseau
3. Installer BDD + Serveur Web + Interface Admin SGBD
apt-get update
apt-get install apache2 mysql-server phpmyadmin
4. Installer Drupal 7 en français
Certaines des commandes suivantes sont à taper dans /var/www/ et d’autres 
dans ~/Téléchargements/

Créer une base de données appelée «drupal».

On récupère Drupal en ligne:
wget http://ftp.drupal.org/files/projects/drupal-x.x.tar.gz -> Remplacer «x.x» par 7.17

On décompresse l’archive:
tar -xzvf drupal-x.x.tar.gz -> Remplacer «x.x» par 7.17

On déplace le dossier obtenu dans le dossier www:
mv drupal-7.17 /var/www
Puis on renomme le dossier:
mv drupal-7.17/ drupal/
On donne le droits sur tout le contenu du dossier drupal:
chmod -R 777 drupal

On peut à présent accéder à drupal par l’interface web:

Suivre les instructions d’installation pour l’installation de la langue Française. Taper les commandes indiquées pour résoudre les erreurs (penser à donner les droits aux éventuels dossiers créés avec la commande chmod 777 nomdudossier).

Connection à la base de données:
Nom: drupal
Nom d’utilisateur: root
mot de passe: toto (mot de passe défini lors de l’installation du SGBD, voir TP n°1)

5. Rédiger 3 articles dont deux en page d’accueil (articles avec image)
6. Changer le thème
On passe par le menu «Apparence».
7. Installer deux modules complémentaires
On passe par le menu «modules» et on en coche 2.

Bonus: Installation d’un nouveau thème
Télécharger l’archive tar.gz du thème. L’extraire dans /var/www/drupal/sites/all/thèmes
Le thème est à présent disponible depuis le menu de sélection du thème.

jeudi 6 décembre 2012

Liste commandes TP Services Réseau n°1


TP Services Réseau n°1
1. Démarrer une VM Linux
2. Configurer le réseau
ifconfig eth0 10.2.18.X netmask 255.255.255.0
route add default gw 10.2.18.1
3. Créer un utilisateur membre des groupes root et users
useradd toto  -> Créer l’utilisateur toto
adduser toto root -> Ajouter l’utilisateur toto au groupe root
adduser toto users -> Ajouter l’utilisateur toto au groupe users
4. Installer nano et vim
apt-get update -> met à jour les sources
apt-get install nano vim -> Installe les paquets nano et vim
5. Créer le fichier lisezmoi.txt avec Vi
   Créer le fichier lisezmoi1.txt avec nano
   Créer le fichier lisezmoi2.txt avec gedit
vi lisezmoi.txt -> Créer le fichier avec Vi
Dans vi: quitter vi en tapant :wq (Write et Quit)

nano lisezmoi1.txt
Dans nano: Ctrl + O pour sauvegarder
Ctrl + X pour quitter

gedit lisezmoi2.txt
6. Modifier les droits de ces fichiers:
lisezmoi.txt RWX R-X --X
lisezmoi1.txt R-X RWX -W-
lisezmoi2.txt RW- R-X R--

chmod 751 lisezmoi.txt -> On change les droits du premier fichier
chmod 572 lisezmoi1.txt
chmod 654 lisezmoi2.txt
ls -l -> On vérifie que les droits sont correctement appliqués
7. Surveiller l’ensemble des processus
ps -> Liste les processus de l’utilisateur
ps -e -> Liste tous les processus du système
8. Installer un SGBD
apt-get install mysql-server -> Installe MySQL 
9. Installer un serveur Web
apt-get install apache2
10. Installer un gestionnaire graphique pour la SGBD
apt-get install phpmyadmin
Pour relancer la config: dpkg-reconfigure phpmyadmin

En cas de problème, regarder sur la page ubuntu.org dédiée à phpmyadmin.



vendredi 23 novembre 2012

Installer Cisco Packet Tracer sous OS X Mountain Lion

Installer Cisco Packet Tracer sous OS X Mountain Lion

 

Prérequis:

Tout d'abord, on récupère Cisco Packet Tracer sur le site de Cisco.

Dans le même temps, on installe PlayOnMac depuis ce site:
http://www.playonmac.com/fr/

Installer Wine:

Une fois PlayOnMac lancé, dans la barre de menu, on navigue jusqu'à Outils -> Gérer les versions de Wine
Dans la liste de gauche, on sélection la version 1.3.26, puis on clique la petite flèche vers la droite pour l'installer.


Installer Packet Tracer:

On revient à la fenêtre principale de PlayOnMac et on clique "Installer un programme", puis "Installer un programme non listé" (en bas à gauche).

Suivant, puis "Installer un programme dans un nouveau disque virtuel". On lui donne le nom "PacketTracer".
Dans la fenêtre suivante, on coche "Utiliser une autre version de Wine"

Dans la nouvelle fenêtre, on choisit bien entendu la version 1.3.26 installée précédemment.

Le disque dur virtuel se crée, puis on nous demande de choisir le fichier d'installation. On navigue jusqu'à l'emplacement de notre exécutable Packet Tracer, puis on clique suivant. Après 6 coups de "next", l'application s'installe enfin.

A la fin de l'installation, on décoche "Lancer Packet Tracer", un clic sur "Finish" et on retourne sur la fenêtre principale de PlayOnMac.

On sélectionne Packet Tracer, on clique Configurer.


Dans "Installer des paquetages", installer vcrun2008 s'il n'est pas déjà installé.


Packet Tracer est maintenant fonctionnel sur Mac !

jeudi 22 novembre 2012

Mémo Routeurs Cisco


Fiche sur les routeurs CISCO


Table des matières




Configuration basique d’un routeur


enable
conf t
interface FastEthernet0/0
ip address 172.2.0.254 255.255.0.0
no shutdown
exit
interface Serial0/0
ip address 192.168.1.2 255.255.255.0
clockrate 128000
no shutdown
exit
interface FastEthernet0/1
ip address 172.18.90.33 255.255.0.0
no shutdown
exit
interface Serial0/1
ip address 192.168.3.2 255.255.255.0
clockrate 128000
no shutdown
exit

ip route 172.4.0.0 255.255.0.0 172.18.90.44 ‘Ajout d’une ligne dans la table de routage
ip route 172.5.0.0 255.255.0.0 172.18.90.44
ip route 172.6.0.0 255.255.0.0 172.18.90.44
ip route 192.168.4.0 255.255.255.0 172.18.90.44
ip route 192.168.6.0 255.255.255.0 172.18.90.44

ip route 172.1.0.0 255.255.0.0 192.168.1.1
ip route 172.3.0.0 255.255.0.0 192.168.3.1

ip route 172.18.0.0 255.255.0.0 172.18.90.44

ip routing ‘Active la table de routage

show ip route ‘Visualisation de la table de routage
exit
--- Rip v.2 et routage ---
ip routing // active le routage sur les sous-réseaux
router rip // active le routage avec le protocole de passerelle interne Rip
version 2 // définit la version de rip utilisé
network 192.168.1.0 // Subnet 1
network 192.168.1.128 // Subnet 2

Sauvegarde de la configuration


copy start tftp
Saisissez l’adresse du serveur Kortex : 10.2.12.4
Tapez Entrée pour confirmer le fichier source
Nommez le fichier : (ex : marcel-g1)

Commandes pratiques


no ip domain-lookup : Enlève toutes les interrogations DNS en cas d’erreurs
enable password {mot de passe} : Limite l’accès au mode privilégié.
enable secret {mot de passe} : Idem que enable password, mais utilise un processus de cryptage propriétaire de Cisco pour modifier la chaîne de caractère du mot de passe.
hostname RouterA : Renomme le routeur
copy running-config startup-config : Enregistrer la configuration (equivalent : copy run start)
show ip int brief : Connaître ses interfaces
no ip route <adr IP><masque> : Supprime une ligne de routage
show clock OU show clock detail: Voir l’heure
clock set 20:30:13 July 2009 OU clock timezone GMT+1 1 : Fixer une heure, un jour, mois, année
debug ip rip / no debug ip rip : Activation/Desactivation de la visualisation des échanges de tables de routages
show ip protocols : Savoir la fréquence des échanges de tables avec les autres routeurs

Tunnel GRE sous iOS


conf t
int tunnel0
ip address 192.40.40.1 255.255.255.0
tunnel source fastEthernet0/1
tunnel destination 10.1.1.1
end

int tunnel0
ip address 192.40.40.2 255.255.255.0
tunnel source fastEthernet0/0
tunnel destination 10.1.3.2
end

/!\ Afin que tous soit opérationnel il faut bien prendre les interface correspondantes aux adresses IP “externe” c a d 10.1.1.1 f0/1 et 10.1.3.2 f0/0 /!\

Pour une meilleure compréhension s’aider de l’image suivante ...
Fin de TP

Décablez toutes les interfaces
erase start pour effacer le startup config et redémarrer le routeur
reload : Redémarre le routeur pour que les changements prennent effet



Documentations


Configuration routeur : http://fr.wikibooks.org/wiki/Configuration_de_routeurs_Cisco
Dans les lignes de la table de routage le C représente les lignes créée par défaut et le S les lignes ajoutées.




Mémo Serveur DHCP Linux


Serveur DHCP sous Linux


Distribution conseillée : UbuntuLucid Wiresharked

Avant d’exécuter les commandes, il faut être en Super Administrateur, pour ce faire, saisir la commande sudo su !

* Changement du nom du serveur
gedit /etc/hostname
//Ouverture du fichier contenant le nom de la machine
// Tester hostname <nom serveur>

* Changer l’@ IP
ifconfig ethx 10.2.18.72 netmask 255.255.255.0

* Ajout de la passerelle
route add default gw 10.2.18.1
// gw => gateway

* Modifier l’@ DNS
gedit /etc/resolv.conf &
//Le fichier contient déjà la ligne nameserver 194.167.159.13 (@ du DNS
// primaire de base).
//La supprimer et la remplacer par nameserver 10.2.12.4
// 10.2.12.4 correspond à l’@ du DNS Kortex qui contient le package du DHCP
* Installer le DHCP
apt-get install dhcp3-server
// Le fail à la fin de l’exécution de la commande est normal, cela signifie qu’il  
// n’est pas configuré (le téléchargement et l’installation ont réussi).
Si la commande ne marche pas, il faut peut être “rafraîchir” le serveur avec la
commande : apt-get update

Pensez à débrancher le réseau de l’IUT une fois l’installation faite pour ne pas faire de conflit !!!

* Configuration du DHCP
gedit /etc/dhcp3/dhcpd.conf
// Dans le fichier, “choisir” une zone à modifier.
// subnet 10.2.18.0 netmask 255.255.255.0 { @ du réseau + masque
// range 10.2.18.74 10.2.18.75 ; étendue du serveur
// option domain-name-server 194.167.156.13 ;  @ du DNS
// option routers 10.2.18.1 ; @ du routeur
// host <nom_machine>  { nom de la machine qui aura la réservation
// hardware ethernet <@mac_machine>  ; @mac de la machine
// fixed-address 10.2.18.74 ; } @ réservée
// }




Liens utiles :

Mémo switchs Cisco


Fiche sur les switchs CISCO

Configuration basique d’un switch


Cabler le port série du switch avec le PC
Régler Putty : Connexion série 9600bits/s, pas de parité, 8 bits de données, pas de contrôle de flux
Appuyer deux fois sur la touche entrée


flash_init ‘Reinit’ le système
load_helper ‘Reinit’ le système
del flash:config.text ‘Supprime l’ancienne config
del flash:vlan.dat ‘Supprime l’ancienne config
boot ‘Démarrer le système

Would you like to enter ... configuration dialog? Y
Would you like to enter... management setup ?
Y
Entrer le nom du switch
Entrer le MDP (ex : toto)
Configure SMTP Network Management ? No
Indiquer l’interface vlan1 pour que l’on puisse administrer le switch à partir du VLAN par défaut
Configurer l’adresse IP de vlan1 en prennant une adr sur l’écran du PC
Enable cluster command switch ? No

Fonctionnement de base du Switch

enable
show mac-address-table ‘Voir la table d’adresses MAC
ex

Spanning Tree

Évite la mise en place de boucle en ‘cassant’ les boucles.

Virtual LAN (VLAN)


show vlan ‘Visualisation des vlans actifs
conf t
vlan 2 ‘Création du vlan 2
name administration ‘Nommer son Vlan
vlan 3
name compta
ex

conf t
interface range fastEthernet 0/3-6 ‘On choisit les int de 3 à 6
switchport mode access ‘Mode du/des ports (1 seul vlan ou trunk)
switchport access vlan 2 ‘Affectation des port dans le vlan 2
ex
interface range fastEthernet 0/7-10
switchport mode access
switchport access vlan 3
ex
ex

interface gigabitEthernet 1/1
switchport mode trunk ‘Activation du mode trunk
switchport trunk allowed vlan all
‘Pour faire passer tout les vlans
OU
switchport trunk allowed vlan 4,6 ‘Faire passer deux vlans 4 et 6
OU
switchport trunk allowed vlan 1-6 ‘Une suite de vlans 1 à 6
ex
ex
Côté routeur:
                    conf t
                            int fastethernet 0/0.20 <= On donne un numéro à la sous interface
                            encapsulation dot1q 2 <= Le numéro du vlan dans lequel se trouve l'interface
                            ip address 192.168.1.1 255.255.255.0
                            no shutdown

Atttention: Après avoir configuré les sous interfaces, accéder à l'interface physique sur laquelle ont été configurées les sous interfaces et faire un nos shutdown
                    conf t
                            int fastethernet 0/0
                            no shutdown

Commandes pratiques (A faire en conf terminal )

no ip domain-lookup : Enlève toutes les interrogations DNS en cas d’erreurs
no vlan X : Supprime un Vlan

Documentation

http://www.croc-informatique.fr/2007/06/procedure-creation-de-vlan-et-configuration-cisco/

Vlan Cisco : http://wiki.zed-network.fr/index.php/Cisco_vlan_trunk_802.1Q
          http://clemanet.com/spanning-tree.php
Doc Cisco : http://www.cisco.com/en/US/products/hw/switches/ps628/products_tech_note09186a0080169696.shtml
Dns loookup : http://www.dharshin.com/2011/04/disable-dns-lookup-in-cisco-routers-and.html